ロリポップ

【ロリポップ手順】PHPバージョン変更【モジュール版】

更新日:

ロリポップでPHPバージョン変更

ロリポップで使用できるPHPバージョンは3種類

参考 ロリポップでは、PHP7.1の場合、モジュール版とCGI版を選ぶことができます。(スタンダードプラン以上)
PHPバージョン
PHP7.1(モジュール版)
PHP7.1(CGI版)
PHP5.6(CGI版)

どのバージョンを選べば良いのか

PHPもバージョンアップをしていくと、脆弱性などが修正されてセキュリティが強化されていきます。

他にもプログラムとしての性能も向上しています。

実際に、PHP7はPHP5に比べて性能が2倍になっていると言われています。

ロリポップではPHP7.1のモジュール版とCGI版について以下のように説明書きがあります。

基本的には、より新しいバージョンのものを選ぶべきです。
モジュール版とCGI版どちらを選ぶかは、それぞれの特徴から自分にあったものを選びましょう。

項目モジュール版CGI版
実行プロセスApacheのプロセスPHPのプロセス
レスポンス高速低速
iniによる設定変更×
提供プランスタンダード、エンタープライズ全てのプラン

ロリポップでPHPのバージョン変更手順

  1. ユーザー専用ページの[サーバーの管理・設定]-[PHP設定]をクリックします。
  2. 変更したいバージョンを選択して[変更]をクリックします。

  3. 続けて確認画面が表示されるので[OK]をクリックします。

  4. 変更が完了したことを確認します。
管理人
とても簡単に変更することができました。

これなら初心者の方も安心して変更できますね。

これから始める人におすすめ2の記事

満足できる!!
レンタルサーバー集

実際に使ってわかった初心者にもおすすめできるサーバーを集めました

すぐに確認する

これで戦える!
WordPressテーマ集

ブログも!アフィリエイトも!
おすすめのテーマ徹底比較

すぐに確認する

-ロリポップ

Copyright© スタープレス , 2019 All Rights Reserved.